Our Preferred 5 Star Hosting Provider - Award Winning FileMaker Pro Hosting
Results 1 to 2 of 2
  1. #1
    Forum Member
    Join Date
    Jul 2014
    Posts
    47
    Location
    Cincinnati, Ohio
    FileMaker Pro Software
    15
    OS
    Windows
    Skill Level
    Intermediate
    Last Post
    11-01-2017
    Local Date
    11-25-2017
    Local Time
    05:31 AM
    Last Active
    11-01-2017

    Printing to two different printers with one script failing

    I am using FM 15 advance. I have a printer server (robot) set to print to two different printers. One printer is an Epson receipt printer the other is a Brother QL 810W label printer. The script only sends to one of two layouts. One layout only prints to the Epson printer, the other only to the Brother printer. The script has a print setup script step prior to the print script step that sets the printer accordingly. The print step then also has the matching printer to print to. The printing was working on each printer fine one day. The following day it was not. The print setup step would change between printers sending the wrong information to the wrong printer. I set the print setup step to dialog on so I could verify what printer was selected. I even used the debugger tool and physically watched the printer change from the one to the other printer in the print setup script step. I host this database on a server from fmphost. My printer server is a Win7 machine. I have also tested this by connecting to the database locally on my win 7 machine. Same messed up results on both hosting situations. I know through other searches that printing is not always pleasant in FM, but I have used this script on other projects before and it works great. The difference is that on my other project that printed to two printers, both printers were Epson receipt printers, so I may not have noticed the print set up step changing since the properties are the same. It always printed to the right printer. Any thoughts/ suggestions?

  2. #2
    Forum Member
    Join Date
    Jul 2014
    Posts
    47
    Location
    Cincinnati, Ohio
    FileMaker Pro Software
    15
    OS
    Windows
    Skill Level
    Intermediate
    Last Post
    11-01-2017
    Local Date
    11-25-2017
    Local Time
    05:31 AM
    Last Active
    11-01-2017

    Problem Solved

    I did not realize it but I had both printer set to the same ip address and that certainly put everything out of wack! Sorry for the post

Thread Information

Users Browsing this Thread

There are currently 3 users browsing this thread. (0 members and 3 guests)

Similar Threads

  1. Replies: 6
    Last Post: 03-09-2013, 02:18 PM
  2. FMP 12 printing issues to HP Laserjet printers
    By LandyAtkinson in forum FileMaker Pro 12 - All versions
    Replies: 0
    Last Post: 10-18-2012, 08:57 AM
  3. Trying to have my clients have access to my database but failing!
    By tinus in forum FileMaker Pro 10 Advanced
    Replies: 0
    Last Post: 03-14-2012, 09:09 PM
  4. Server failing to close client connections properly
    By svend in forum FileMaker Pro Server and Networking
    Replies: 10
    Last Post: 02-28-2011, 12:48 AM
  5. Creating a VOTE TABUATOR (failing)
    By Randy in forum Calculations and Define Fields
    Replies: 3
    Last Post: 06-04-2002, 03:12 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Welcome to the Original FileMaker Forum
With designated forums for almost every FileMaker topic...FileMaker Today is a FREE to join community where you can boost your FileMaker expertise, build better apps & solutions and interact with over 42,000+ FileMaker Developers from all over the world. If you're building FileMaker solutions, this is the place for you.
Follow FMT
We Are FMT
FMT is home of The World's leading FileMaker News Site, Worldwide Developer Directory, FileMaker Connect Community and so much more.